Yet with up2date in Fedora, WTF!

At ending of October I was suffering this error when I try to make yum update and I answer yes in order to install all that yum purposes to me:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package up2date needs python(abi) = 2.4, this is not available.
Package rhnlib needs python(abi) = 2.4, this is not available.
Complete!

It has been easy at the end… as you may see, that messages shows that my Fedora has yet installed a up2date package. Since I really don’t use at all I took it out by typing: yum erase up2date and so on…
But the questions are two:

  1. Why are there an up2date package in Fedora? a legacy question comming fron the ancient RedHat 8 and 9 ages?
  2. How many others useless packages do I have installed?

So I was thinking all around this stuff I two mini-projects come to my mind:

  • Writte a couple of scripts that retrieves what packages do I have ordered by use: I have no idea if there’s some method to retrieve package use frequency, but as I’ve just say it’s just an idea, let’s see if it possible or it isn’t…
  • Writte a couple of scripts that retrieves for every single package what other packages depends on it and viceversa, by the way, I’ve imagine the reports writed under some xml strict DTD so may open it in a browser or read from some other script or import it in a database

Post a Comment

Your email is never shared. Required fields are marked *

*
*